Results 1 to 4 of 4

Thread: Xplorer 2 Rod quality ?

  1. #1
    Join Date
    Dec 2013
    Location
    cape town
    Posts
    18

    Default Xplorer 2 Rod quality ?

    Hi All

    Has anyone ever had an issue with a rod piece detaching while casting.

    I've never had this issue with my 9ft9wt elbe 2 piece.

    But it is a common issue with my 9ft6wt xplorer 2, 3 piece.

    Should i return the rod ?

    The top section comes off once almost every outing...

    And now i've resorted to tightening it so much that it's a mission to break it up again when done.

  2. #2
    Join Date
    Mar 2012
    Location
    eastern cape
    Posts
    32

    Default

    Yes I have take some bees wax or candle wax and rub some on the piece that inserts in to the other piece it should sort the problem out

  3. #3
    Join Date
    Mar 2011
    Location
    Richards Bay, Kwazulu Natal
    Posts
    472
    Blog Entries
    1

    Default

    Seen 3 Xplorer Rods break ferules due to the sections slipping in one week

    Add some wax as suggested, taking it back wont solve the problem. Its the tolerances the blanks are built to...
    Adopt the pace of nature: her secret is patience - "Ralph Waldo Emerson"
    www.flyordie.co.za

  4. #4
    Join Date
    Dec 2013
    Location
    cape town
    Posts
    18

    Default

    Thanks Guys

    Didn't know that one !

    Landed another leery at klein brak today

    It is officially my new favorite leery spot

    Hopefully breede will reclaim that crown when i go up in a few days ...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •